If you run PHP below 8.5.12, 8.4.27, 8.3.36 or 8.2.35, treat two critical flaws as urgent: update, restart workers and check logs. CISA lists both as exploited. A web firewall is only an interim control.
- 01CVE-2026-109618 and CVE-2026-109619 allow unauthenticated remote code execution; CISA added both to its exploited-vulnerabilities catalogue on 26 October 2026.
- 02Magento, Adobe Commerce and WordPress sites run on PHP, so ask your host which version and interface each site uses.
- 03PHP 8.1 and earlier are not among the fixed releases: CISA says to take such systems offline until patched or upgraded.
- 04Patching does not show whether the flaws were used earlier, so review logs as well.
Are you affected?
Probably, if any website or application you run uses PHP below 8.5.12, 8.4.27, 8.3.36 or 8.2.35. That includes many Magento, Adobe Commerce and WordPress sites, because they run on PHP. This is Noesis analysis of the advisories, not a statement by those vendors. CISA's alert, updated on 26 October 2026, covers every PHP installation serving web requests, including Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP and LiteSpeed. CISA calls out PHP 8.1 and earlier as unsupported, and they are not among the fixed releases. Your hosting provider may patch for you, so ask rather than assume. See sources 1–3.
What is confirmed, and when.
The PHP project published two critical advisories on GitHub on 21 October 2026. php.net's changelog lists releases 8.5.12 and 8.4.27 on 22 October; we did not read its 8.3.36 and 8.2.35 entries. CISA updated its alert on 23 October and added both CVEs to its Known Exploited Vulnerabilities (KEV) catalogue on 26 October. Addition to the catalogue is CISA's signal that exploitation has been observed. The entries give a due date of 29 October and record use in ransomware campaigns as 'Unknown'. Neither the advisories nor CISA says who is exploiting the flaws or how widely. We checked these sources on 30 October 2026. See sources 1–5.
From advisory to exploited-vulnerability listing in five days
- Advisories publishedTwo critical php-src advisories name the fixed releases
- Releases in php.net changelog8.5.12 and 8.4.27 are dated this day
- CISA alert updatedDetection rule and mitigation guidance added
- Added to CISA KEVBoth CVEs listed in the catalogue
- Catalogue due dateAs recorded in the catalogue entries
What the advisories describe.
Each advisory carries a CVSS v4 score of 9.2 and lists the same affected and fixed versions. CVE-2026-109618, titled 'RCE via OOM corruption', concerns how PHP handles a failed memory allocation. CVE-2026-109619, titled 'RCE via stale global state', concerns state kept from an earlier request. The first advisory reports validated unauthenticated remote code execution over HTTP against mod_php with default settings. It judges PHP-FPM likely susceptible but unproven, and FrankenPHP and LSAPI likely susceptible. The second describes a confirmed route through session upload progress and PHP 8.5's fatal error backtraces on mod_php, and says exploitation needs the producing and consuming requests to reach the same worker. We do not repeat technical detail beyond the advisories. See sources 1–2.
Two critical flaws, one fix
| Aspect | CVE-2026-109618 | CVE-2026-109619 |
|---|---|---|
| Advisory title | RCE via OOM corruption | RCE via stale global state |
| Severity | Critical, CVSS v4 9.2 | Critical, CVSS v4 9.2 |
| Fixed in | 8.5.12, 8.4.27, 8.3.36, 8.2.35 | Same fixed releases |
| Confirmed route | Unauthenticated RCE over HTTP on mod_php, default settings | Session upload progress and PHP 8.5 fatal error backtraces on mod_php |
What to do this week.
Noesis recommendation, following CISA's steps. First inventory every system that runs PHP, including PHP embedded in other software, and put internet-facing systems first. Then update to a fixed release and restart workers so the new version is the one running. Confirm the running version afterwards, not just the package installed. If a system cannot be updated, or runs PHP 8.1 or earlier, CISA says to take it offline until it is patched or upgraded. Finally review logs for PHP worker processes launching shells or downloading tools, and use CISA's published SIGMA detection rule. Clean logs do not prove safety. See sources 1–3.
The week’s steps, in order
- 01Inventory PHPEvery system, including PHP embedded in other software
- 02Update to a fixed releaseInternet-facing systems first
- 03Restart and confirm versionThe running version, not just the installed package
- 04Offline if it cannot be updatedAlso for PHP 8.1 and earlier, per CISA
- 05Review logsWorker processes launching shells or downloading tools
Interim controls and their limits.
A web application firewall may give some protection until systems are patched, according to CISA. The advisories say upgrading is the only complete fix. For 8.5 installations that cannot yet update, setting fatal_error_backtraces=0 and restarting all workers removes the confirmed producer for the second flaw but not other paths. Setting session.upload_progress.enabled=0 and restarting workers blocks the demonstrated session path; the advisory suggests it even after patching if the feature is unused. The first advisory also lists setting memory_limit=-1, keeping request size limits conservative and not using RLIMIT_AS or RLIMIT_DATA, none of which is a complete mitigation. See sources 1–3.
If you cannot update yet
- 01Web application firewall in front of PHPPass when: May give some protection until patched (CISA)
- 02PHP 8.5, cannot update yetPass when: fatal_error_backtraces=0, workers restarted; removes the confirmed producer only
- 03Session upload progress not neededPass when: session.upload_progress.enabled=0, workers restarted
- 04PHP 8.1 or earlier, or cannot updatePass when: Offline until patched or upgraded (CISA)
What not to conclude.
Do not conclude that your site has been compromised because it ran an older PHP, or that it is safe because a patch has been applied since. Patching closes the flaw going forward and does not show whether anyone used it earlier. Do not rely on press reports of scale; the sources we read do not state how many systems are affected. We did not verify a separate configuration-dependent issue, CVE-2026-115560, reported on 23 October, so this note does not cover it. This is not legal advice, and we have not tested any system against these flaws.
Make the first check concrete.
Noesis analysis: ask your hosting provider and your developers three questions today. Which PHP version and server interface runs each production site? When was it last restarted after updating? Who reviews the logs? If the answers are unclear, an inventory of the web estate is the useful first piece of work, ahead of any redesign.
Sources & context
Sources checked 2026-10-30. Recommendations and illustrative scenarios are Noesis’s analysis, not claims of client results.
- 1 / PHP project — GitHub advisory GHSA-w8hw-w9fx-j79w (CVE-2026-109618, RCE via OOM corruption); published 21 October 2026; accessed 30 October 2026 ↗
- 2 / PHP project — GitHub advisory GHSA-6wmf-4rv5-p3rp (CVE-2026-109619, RCE via stale global state); published 21 October 2026; accessed 30 October 2026 ↗
- 3 / CISA — Critical Vulnerabilities in PHP Require Immediate Patching; alert dated 21 October 2026, updated 23 and 26 October; accessed 30 October 2026 ↗
- 4 / CISA — Known Exploited Vulnerabilities catalogue; both CVEs added 26 October 2026; accessed 30 October 2026 ↗
- 5 / php.net — PHP 8 ChangeLog; 8.5.12 and 8.4.27 dated 22 October 2026; accessed 30 October 2026 ↗
